当前位置:首页 > 硬件/嵌入开发 > 嵌入开发

搭建linux平台交叉编译,使用eclipse裸机调试6410,有个gdb的有关问题

优良自学吧提供搭建linux平台交叉编译,使用eclipse裸机调试6410,有个gdb的有关问题,搭建linux平台交叉编译,使用eclipse裸机调试6410,有个gdb的问题搭建linux平台交叉编译,使用eclipse裸机调试6410,有个gdb的问

搭建linux平台交叉编译,使用eclipse裸机调试6410,有个gdb的问题
搭建linux平台交叉编译,使用eclipse裸机调试6410,有个gdb的问题就是,之前已经安装了arm-linux-gcc工具,现在使用eclipse裸机调程序要使用正确的GDB版本,之前安装的arm-linux-gcc-4.3.2里面包含的arm-linux-gdb是6.8.50.2008  ;安装时添加如下如下环境变量:
export PATH=/usr/local/arm/4.3.2/bin:$PATH
export TOOLCHAIN=/usr/local/arm/4.3.2 
export TB_CC_PREFIX=arm-linux- 
export PKG_CONFIG_PREFIX=$TOOLCHAIN/arm-none-linux-gnueabi 
可以使用直接调用arm-linux-gcc ,arm-linux-gdb 等命令
现在我更新GDB版本下载安装gdb7.8版本,基本参考这位大神的安装:http://blog.csdn.net/kangear/article/details/8635029
新版本的GDB的输出目录为:  /opt/arm-linux-gdb/bin
发现当我添加新的环境变量如下:
eport PATH=/opt/arm-linux-gdb/bin:$PATH

export PATH=/usr/local/arm/4.3.2/bin:$PATH
export TOOLCHAIN=/usr/local/arm/4.3.2 
export TB_CC_PREFIX=arm-linux- 
export PKG_CONFIG_PREFIX=$TOOLCHAIN/arm-none-linux-gnueabi 
就是增加port PATH=/opt/arm-linux-gdb/bin:$PATH
目的就是想调用arm-linux-gdb时不会去打开/usr/local/arm/4.3.2/bin/ 里面的arm-linux-gdb(6.8版),而是调用 /opt/arm-linux-gdb/bin里面的arm-linux-gdb(7.8版)。
当我生效环境变量时source /etc/profile 后再次使用终端执行#arm-linux-gdb -v 查看版本信息是还是6.8版本,完全没有调用7.8版本啊!!!!
各路大神求破,急啊

------解决思路----------------------
去 etc/profile 里面吧6.8 的环境变量地址删除了   

(本文来自互联网,不代表搜站(http://www.ylzx8.cn/)的观点和立场)
本站所有内容来自互联网,若本站收录的信息无意侵犯了贵司版权,请给我们来信(ylzx8cn@163.com),我们会及时处理和回复,谢谢