当前位置:首页 > 数据库 > Oracle技术

cent os 6.3上安装oralce11gr2遇到有关问题请大家帮帮忙

优良自学吧提供cent os 6.3上安装oralce11gr2遇到有关问题请大家帮帮忙,cent os 6.3上安装oralce11gr2遇到问题请大家帮帮忙版本信息: cent os 6.3 final Linux version 2.6.32-279.el6.x86_64 (mockbuild@c6b9.bsys.dev.cent

cent os 6.3上安装oralce11gr2遇到问题请大家帮帮忙
版本信息:
cent os 6.3 final

Linux version 2.6.32-279.el6.x86_64 (mockbuild@c6b9.bsys.dev.centos.org) (gcc version 4.4.6 20120305 (Red Hat 4.4.6-4) (GCC) ) #1 SMP Fri Jun 22 12:19:21 UTC 2012

安装过程中出现错误
cent os 6.3上安装oralce11gr2遇到有关问题请大家帮帮忙

这里说我很多包没有打,可是实际上我都已经装上了比 要求版本更新的包
比如图片中的libaio-0.3.105
我检查我的系统
[chengjun@AY130821162629608367Z ~]$ rpm -qa | grep libaio
libaio-devel-0.3.107-10.el6.x86_64
libaio-devel-0.3.107-10.el6.i686
libaio-0.3.107-10.el6.i686
libaio-0.3.107-10.el6.x86_64


可是如果我真的视图去安装要求的版本,又会报错

[chengjun@AY130821162629608367Z ~]$ sudo rpm -ivh libaio-0.3.105-2.i386.rpm
warning: libaio-0.3.105-2.i386.rpm: Header V3 DSA/SHA1 Signature, key ID 73307de6: NOKEY
Preparing...                ########################################### [100%]
        package libaio-0.3.107-10.el6.x86_64 (which is newer than libaio-0.3.105-2.i386) is already installed
        package libaio-0.3.107-10.el6.i686 (which is newer than libaio-0.3.105-2.i386) is already installed


这里要求的所有的包,我的系统中都有更高级的版本
而且我对问题中说的swap size的问题也很糊涂
我的磁盘情况是这样的

/dev/xvda1             20G   14G  4.8G  75% /
tmpfs                 7.8G  607M  7.2G   8% /dev/shm
/dev/xvdb1            719G  270G  413G  40% /data

我把我的ORACLE_BASE放在了/data下面,保证了磁盘空间
可是这里的swap size问题怎么才能解决呢?
请大家帮帮忙
谢谢啦。
------解决思路----------------------
这个包有包依赖需要你把其依赖的包都装上,可以配置yum来安装,yum会自动安装其依赖的包。
yum的配置过程非常简单http://blog.csdn.net/ora_raymond/article/details/10388711
------解决思路----------------------
建议使用安装镜像配置一个本地yum源。
你分区的时候有没有创建交换空间?你给的磁盘情况没看出来有交换空间
------解决思路----------------------
楼主 这个问题解决了吗?
------解决思路----------------------
swap size那个问题可以忽略,不影响安装,我当时装的时候也检查出这个问题

(本文来自互联网,不代表搜站(http://www.ylzx8.cn/)的观点和立场)
本站所有内容来自互联网,若本站收录的信息无意侵犯了贵司版权,请给我们来信(ylzx8cn@163.com),我们会及时处理和回复,谢谢